1 # Maintainer: Rémy Oudompheng <remy@archlinux.org>
2 # Maintainer: Firmicus <firmicus āt gmx dōt net>
8 pkgdesc="TeX Live - Setups for typesetting various board games, including chess"
11 depends=('texlive-core')
12 groups=('texlive-most')
13 url='http://tug.org/texlive/'
14 source=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip" "$pkgname.maps")
15 options=('!emptydirs')
16 sha256sums=('77a4e0293e5cba64e40b4b0add46e722f4e258f90812d2d53715fe0f3c0080f7'
17 'a4e19b3d6cf8701565d8732c0ff3ee037510b6fb3af53257311bf0731112d72b')
24 rm -rf {tlpkg,doc,source} || true
29 install -m755 -d "$pkgdir"/var/lib/texmf/arch/installedpkgs
30 sed -i '/^#/d' CONTENTS
31 install -m644 CONTENTS "$pkgdir"/var/lib/texmf/arch/installedpkgs/${pkgname}_${_revnr}.pkgs
32 install -m644 $pkgname.maps "$pkgdir"/var/lib/texmf/arch/installedpkgs/
33 install -m755 -d "$pkgdir"/usr/share
34 wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
35 for dir in $wanteddirs; do
36 find $dir -type d -exec install -d -m755 "$pkgdir"/usr/share/texmf-dist/'{}' \;
37 find $dir -type f -exec install -m644 '{}' "$pkgdir"/usr/share/texmf-dist/'{}' \;
39 if [[ -d texmf-dist ]]; then
40 find texmf-dist -type d -exec install -d -m755 "$pkgdir"/usr/share/'{}' \;
41 find texmf-dist -type f -exec install -m644 '{}' "$pkgdir"/usr/share/'{}' \;
43 if [[ -d "$pkgdir"/usr/share/texmf-dist/scripts ]]; then
44 find "$pkgdir"/usr/share/texmf-dist/scripts -type f -exec chmod a+x '{}' \;
46 install -m755 -d "$pkgdir"/usr/bin
47 ln -s /usr/share/texmf-dist/scripts/rubik/rubikrotation.pl "$pkgdir"/usr/bin/rubikrotation