archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xdg-desktop-portal-gnome / trunk / PKGBUILD
blobee1d1fa7d1f7f7bac46037dacb7aa7ee644572c1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=xdg-desktop-portal-gnome
4 pkgver=43.1
5 pkgrel=1
6 pkgdesc="A backend implementation for xdg-desktop-portal for the GNOME desktop environment"
7 url="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=('xdg-desktop-portal-gtk>=1.10.0-2' libadwaita gnome-keyring
11          gnome-desktop-4)
12 makedepends=(xdg-desktop-portal meson git)
13 optdepends=('evince: Print previews')
14 provides=(xdg-desktop-portal-impl)
15 conflicts=('xdg-desktop-portal-gtk<1.10.0-2')
16 replaces=('xdg-desktop-portal-gtk<1.10.0-2')
17 options=(debug)
18 _commit=4fd5a8bf16b01c78ed19764415cb26d29aaf7eab  # tags/43.1^0
19 source=("git+https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome.git#commit=$_commit")
20 sha256sums=('SKIP')
22 pkgver() {
23   cd $pkgname
24   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd $pkgname
31 build() {
32   arch-meson $pkgname build
33   meson compile -C build
36 check() {
37   meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"
44 # vim:set sw=2 sts=-1 et: