db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / epiphany / trunk / PKGBUILD
bloba8897034c28983047dbf288eaa2dd16e5b654e61
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=epiphany
5 pkgver=44.2
6 pkgrel=1
7 pkgdesc="A GNOME web browser based on the WebKit rendering engine"
8 url="https://wiki.gnome.org/Apps/Web"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   gcr-4
13   gstreamer
14   gtk4
15   icu
16   libadwaita
17   libarchive
18   libportal-gtk4
19   libsoup3
20   webkitgtk-6.0
22 makedepends=(
23   docbook-xml
24   git
25   gobject-introspection
26   lsb-release
27   meson
28   startup-notification
29   yelp-tools
31 checkdepends=(
32   aspell
33   hspell
34   hunspell
35   libvoikko
36   nuspell
37   xorg-server-xvfb
39 groups=(gnome)
40 _commit=707137ffbd20ed6fc143094f7a46ddf929f603ba  # tags/44.2^0
41 source=(
42   "git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit"
43   fix-test.diff
45 b2sums=('SKIP'
46         '05121ff5f759ec637a718c9b39406f9a384227a312d69f6dc74e73fde8351689d588a30dddea3cfe0a6edb094fdcf5382eb5ff725bb2adfccdff87ab3cf4c953')
48 pkgver() {
49   cd epiphany
50   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
53 prepare() {
54   cd epiphany
56   # Fix encoding test; perhaps caused by different glibc or locale env
57   # https://gitlab.gnome.org/GNOME/epiphany/-/issues/1842
58   git apply -3 ../fix-test.diff
61 build() {
62   arch-meson epiphany build
63   meson compile -C build
66 check() {
67   WEBKIT_DISABLE_SANDBOX_THIS_IS_DANGEROUS=1 \
68     dbus-run-session xvfb-run -s '-nolisten local' \
69     meson test -C build --print-errorlogs
72 package() {
73   meson install -C build --destdir "$pkgdir"
76 # vim:set sw=2 sts=-1 et: