db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-screenshot / trunk / PKGBUILD
blob9e6b0f7883b9a41afa4bd2972b4a3d0465a6ecb3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-screenshot
5 pkgver=41.0+r25+g45f08f0
6 pkgrel=1
7 pkgdesc="Take pictures of your screen"
8 url="https://gitlab.gnome.org/GNOME/gnome-screenshot"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(gtk3 libhandy)
12 makedepends=(git meson appstream-glib)
13 _commit=45f08f0b91a7b2aa589c9b3add671e144207e37a  # master
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-screenshot.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 et: