db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / grep / repos / core-x86_64 / PKGBUILD
blobd2f874e61cc37589cf3d24efba5f8da2ca1422d5
1 # Maintainer: Sébastien Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
5 pkgname=grep
6 pkgver=3.10
7 pkgrel=1
8 pkgdesc='A string search utility'
9 arch=('x86_64')
10 license=('GPL3')
11 url='https://www.gnu.org/software/grep/'
12 depends=('glibc' 'pcre2')
13 makedepends=('texinfo')
14 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
15 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
16 sha256sums=('24efa5b595fb5a7100879b51b8868a0bb87a71c183d02c4c602633b88af6855b'
17             'SKIP')
19 prepare() {
20   cd $pkgname-$pkgver
21   # apply patch from the source array (should be a pacman feature)
22   local src
23   for src in "${source[@]}"; do
24     src="${src%%::*}"
25     src="${src##*/}"
26     [[ $src = *.patch ]] || continue
27     msg2 "Applying patch $src..."
28     patch -Np1 < "../$src"
29   done
32 build() {
33   cd $pkgname-$pkgver
34   # configure option --without-included-regex removed in 3.7
35   # see: https://lists.gnu.org/archive/html/bug-grep/2021-08/msg00028.html
36   ./configure --prefix=/usr
37   make
40 check() {
41   cd $pkgname-$pkgver
42   make check
45 package() {
46   cd $pkgname-$pkgver
47   make DESTDIR="$pkgdir" install