1 # Maintainer: Sébastien Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
8 pkgdesc='A string search utility'
11 url='https://www.gnu.org/software/grep/'
12 depends=('glibc' 'pcre2')
13 makedepends=('texinfo')
14 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
15 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
16 sha256sums=('24efa5b595fb5a7100879b51b8868a0bb87a71c183d02c4c602633b88af6855b'
21 # apply patch from the source array (should be a pacman feature)
23 for src in "${source[@]}"; do
26 [[ $src = *.patch ]] || continue
27 msg2 "Applying patch $src..."
28 patch -Np1 < "../$src"
34 # configure option --without-included-regex removed in 3.7
35 # see: https://lists.gnu.org/archive/html/bug-grep/2021-08/msg00028.html
36 ./configure --prefix=/usr
47 make DESTDIR="$pkgdir" install