db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / kaccounts-integration / trunk / PKGBUILD
blobb4475648dd5a346268b71deef228295293a54c4c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org> 
3 pkgname=kaccounts-integration
4 pkgver=23.04.0
5 pkgrel=1
6 pkgdesc='Online account management system and its Plasma integration components'
7 arch=(x86_64)
8 url='https://www.kde.org/'
9 license=(GPL)
10 depends=(kcmutils signon-kwallet-extension signon-plugin-oauth2 signon-ui)
11 makedepends=(extra-cmake-modules kdoctools qcoro-qt5)
12 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('9a068cf7579ca376a27abee31ca0b2a6544b0a08d1f204d88a4833c41d8ae698'
14             'SKIP')
15 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
16               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
17               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
19 build() {
20   cmake -B build -S $pkgname-$pkgver \
21     -DBUILD_TESTING=OFF
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build