db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / kfourinline / trunk / PKGBUILD
blob65e835fc3f3507cdfb427c3049284796ae046b90
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kfourinline
6 pkgver=23.04.0
7 pkgrel=1
8 pkgdesc='A four-in-a-row game'
9 url='https://apps.kde.org/kfourinline/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-games)
13 depends=(libkdegames hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('cc83133ec4fa17453ef698f2717d856599c5414f01d98b7cbfea5ee131222cb6'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build