1 #Maintainer: Juergen Hoetzel <juergen@archlinux.org>
6 pkgdesc="An Objective Caml interface to gtk2"
9 url="http://lablgtk.forge.ocamlcore.org/"
10 depends=('gtk2' 'librsvg')
11 makedepends=('ocaml' 'ocaml-compiler-libs>=4.14.0' 'camlp5')
12 optdepends=('ocaml: for using the tools')
13 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/garrigue/lablgtk/archive/${pkgver}.tar.gz" gcc10.patch)
14 sha512sums=('284a1234ae817c4df49809d28c103ca5e64046da5ec9ff28c6edc0ce999e9d3e6e180dd053f8b1663d4fb3b7ba19570d53b9441c8fa622add924e8d85e41b813'
15 '0fcb9f333101c5ab04dde1729a9c9805e422f100f79ad8014a3cd8c5cb78d19344292e334d4cc70d3614a41a4e143a30cd707b67a8443fa8b6f8c8fc9d7f27d9')
16 options=(!makeflags staticlibs !lto)
19 cd "${srcdir}/lablgtk-${pkgver}/src"
20 patch -p0 -i "${srcdir}/gcc10.patch"
24 cd "${srcdir}/lablgtk-${pkgver}"
25 ./configure --prefix=/usr \
27 --without-gnomecanvas \
30 --without-gtksourceview \
31 --without-gtksourceview2 \
33 sed -e "s|-O|$CFLAGS|" \
34 -e "s|-shared|& -ccopt \"$LDFLAGS\"|" \
35 -e "s|(CAMLMKLIB)|& -ldopt \"$LDFLAGS\"|" \
42 cd "${srcdir}/lablgtk-${pkgver}"
43 make DESTDIR="${pkgdir}" old-install
44 install -m644 META "${pkgdir}/usr/lib/ocaml/lablgtk2/"