db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / ldb / trunk / PKGBUILD
blob92eeb8108ced064b01d6603ec3e4ed7b549d2f57
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Christian Hesse <mail@eworm.de>
3 # Contributor: Marco A Rojas <marquicus at gmail dot com>
5 pkgname=ldb
6 pkgver=2.7.2
7 pkgrel=2
8 epoch=2
9 pkgdesc='Schema-less, ldap like, API and database'
10 arch=('x86_64')
11 url="https://ldb.samba.org/"
12 source=(https://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar{.gz,.asc})
13 license=('GPL3')
14 depends=('talloc' 'libtevent.so' 'tdb' 'libtdb.so' 'popt' 'lmdb')
15 makedepends=('python' 'cmocka' 'docbook-xsl' 'tevent')
16 optdepends=('python: for python bindings')
17 provides=(libldb.so)
18 validpgpkeys=('9147A339719518EE9011BCB54793916113084025') # Samba Library Distribution Key <samba-bugs@samba.org>
19 sha512sums=('beb2cd83a8f128713e0b43ec6e80d0f87ab0883c6c8f0cefbbf5bf49e29dfa327b245b78467d1906917cb5f3f11e01cb76cc6bcca58a47c5deac4f05c2e9dfbd'
20             'SKIP')
22 build() {
23   cd ${pkgname}-${pkgver}
24   ./configure \
25     --prefix=/usr \
26     --disable-rpath \
27     --disable-rpath-install \
28     --bundled-libraries=NONE \
29     --builtin-libraries=replace \
30     --with-modulesdir=/usr/lib/ldb/modules \
31     --with-privatelibdir=/usr/lib/ldb
32   make
35 package() {
36   cd ${pkgname}-${pkgver}
37   make DESTDIR="${pkgdir}" install
40 # vim: ts=2 sw=2 et: