db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / libb2 / trunk / PKGBUILD
blob67d88cddc92fb9f83e0d93be729eb94f063cd972
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Lex Black <autumn-wind@web.de>
3 # Contributor: Jesin <Jesin00@gmail.com>
5 pkgname=libb2
6 pkgver=0.98.1
7 pkgrel=2
8 arch=(x86_64)
9 pkgdesc='C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions'
10 url='https://blake2.net/'
11 license=(custom:CC0)
12 depends=(gcc-libs)
13 source=("https://github.com/BLAKE2/libb2/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e')
16 # libb2's build system discards the $CFLAGS variable.
17 # We can get around this by putting those flags in $CC.
18 export CC="${CC-cc} $CFLAGS"
20 build() {
21   cd "$pkgname-$pkgver"
22   ./configure --prefix=/usr --disable-static --enable-shared --disable-native --enable-fat
23   make
26 check() {
27   cd $pkgname-$pkgver
28   make check
31 package() {
32   cd $pkgname-$pkgver
33   make DESTDIR="$pkgdir" install
34   install -Dm644 COPYING -t "$pkgdir"/usr/share/licenses/$pkgname