1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Lex Black <autumn-wind@web.de>
3 # Contributor: Jesin <Jesin00@gmail.com>
9 pkgdesc='C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp hash functions'
10 url='https://blake2.net/'
13 source=("https://github.com/BLAKE2/libb2/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('53626fddce753c454a3fea581cbbc7fe9bbcf0bc70416d48fdbbf5d87ef6c72e')
16 # libb2's build system discards the $CFLAGS variable.
17 # We can get around this by putting those flags in $CC.
18 export CC="${CC-cc} $CFLAGS"
22 ./configure --prefix=/usr --disable-static --enable-shared --disable-native --enable-fat
33 make DESTDIR="$pkgdir" install
34 install -Dm644 COPYING -t "$pkgdir"/usr/share/licenses/$pkgname