db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / libcryptui / repos / extra-x86_64 / PKGBUILD
bloba9ea7c31eb73456bc0a61fcf913225266af5084b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=libcryptui
5 pkgver=3.12.2+r71+ged4f890e
6 pkgrel=1
7 epoch=1
8 pkgdesc="Library for OpenPGP prompts"
9 url="https://gitlab.gnome.org/GNOME/libcryptui"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(gtk3 gpgme dbus-glib libnotify gcr dconf libsm)
13 makedepends=(intltool gobject-introspection gnome-common git)
14 provides=(libcryptui.so)
15 options=(debug)
16 _commit=ed4f890ee29b94c1bedd7030d5c857e3b9edb465  # master
17 source=("git+https://gitlab.gnome.org/GNOME/libcryptui.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
27   NOCONFIGURE=1 ./autogen.sh
30 build() {
31   cd $pkgname
32   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
33               --disable-static --disable-schemas-compile --enable-gtk-doc
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 package() {
39   cd $pkgname
40   make DESTDIR="$pkgdir" install
43 # vim:set sw=2 sts=-1 et: