1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: kevin <kevin@archlinux.org>
10 pkgdesc='Network Time Protocol reference implementation'
11 url='http://www.ntp.org/'
14 depends=('openssl' 'perl' 'libcap' 'libedit')
15 backup=('etc/ntp.conf')
16 source=("https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${_pkgname}-${_pkgver}.tar.gz"
17 'ntp-4.2.8_p15-glibc-2.34.patch'
22 sha1sums=('e34e5b6f48c3ed1bbcfb03080dec1b8f91e19381'
23 '1423b8ef72a3806ed74affc1973f66ed7cfa2afb'
24 'ad1d6ee2e9aca64a84a7224c88bf6008ac6c69e1'
25 '0cccca872385e0142888ab48d273fec0669b30a8'
26 '059b382d1af0c55202e2d17f2ae065a2cbfec9ee'
27 'e8d1c895eabeb45b1a5f096fa5fc3c088eb3ee71')
28 options=('!emptydirs')
31 cd "${srcdir}/${_pkgname}-${_pkgver}"
32 patch -Np1 -i ../ntp-4.2.8_p15-glibc-2.34.patch
36 cd "${srcdir}/${_pkgname}-${_pkgver}"
38 ./configure --prefix=/usr --libexecdir=/usr/lib --enable-linuxcaps --enable-ntp-signd
43 cd "${srcdir}/${_pkgname}-${_pkgver}"
45 make DESTDIR="${pkgdir}" install
47 install -Dm644 ../ntp.conf "${pkgdir}"/etc/ntp.conf
48 install -Dm644 ../ntpd.service "${pkgdir}"/usr/lib/systemd/system/ntpd.service
49 install -Dm644 ../ntpdate.service "${pkgdir}"/usr/lib/systemd/system/ntpdate.service
50 install -Dm644 ../ntp.sysusers "${pkgdir}"/usr/lib/sysusers.d/ntp.conf
51 install -Dm644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
53 install -d -o 87 "${pkgdir}"/var/lib/ntp
54 echo > "${pkgdir}/var/lib/ntp/.placeholder"