db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / opus / repos / extra-x86_64 / PKGBUILD
blobfea0984bc0b55d60c77bf672f01175729dc6d6d4
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
4 # Contributor: pumbur
6 pkgbase=opus
7 pkgname=(
8   opus
9   opus-docs
11 pkgver=1.4
12 pkgrel=1
13 pkgdesc="Totally open, royalty-free, highly versatile audio codec"
14 url="https://www.opus-codec.org/"
15 arch=(x86_64)
16 license=(BSD)
17 depends=(
18   glibc
20 makedepends=(
21   doxygen
22   git
23   meson
25 _commit=82ac57d9f1aaf575800cf17373348e45b7ce6c0d  # tags/v1.4^0
26 source=("git+https://github.com/xiph/opus#commit=$_commit")
27 b2sums=('SKIP')
29 pkgver() {
30   cd opus
31   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
34 prepare() {
35   cd opus
38 build() {
39   local meson_options=(
40     -D asm=disabled
41     -D custom-modes=true
42   )
44   arch-meson opus build "${meson_options[@]}"
45   meson compile -C build
48 check() {
49   meson test -C build --print-errorlogs
52 package_opus() {
53   provides=(libopus.so)
55   meson install -C build --destdir "$pkgdir"
56   install -Dt "$pkgdir/usr/share/aclocal" -m644 opus/opus.m4
58   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 opus/COPYING
60   mkdir -p doc/usr/share
61   mv {"$pkgdir",doc}/usr/share/doc
64 package_opus-docs() {
65   pkgdesc+=" (documentation)"
66   depends=()
68   mv doc/* "$pkgdir"
71 # vim:set sw=2 sts=-1 et: