db-move: moved seahorse from [testing] to [extra] (x86_64)
[arch-packages.git] / xsd / repos / extra-x86_64 / PKGBUILD
blobd089216a4c2decfde76100a18f51eca71094c153
1 # Maintainer:
2 # Contributor: kevku <kevku@gmx.com>
4 pkgname=xsd
5 pkgver=4.0.0
6 _pkgver=4.0.0+dep
7 pkgrel=5
8 pkgdesc='An open-source, cross-platform W3C XML Schema to C++ data binding compiler'
9 arch=(x86_64)
10 url='https://www.codesynthesis.com/products/xsd'
11 license=(GPL2)
12 depends=(xerces-c)
13 source=(https://www.codesynthesis.com/download/${pkgname}/4.0/${pkgname}-${_pkgver}.tar.bz2
14         xsdcxx.patch
15         gcc-11.patch)
16 sha256sums=('eca52a9c8f52cdbe2ae4e364e4a909503493a0d51ea388fc6c9734565a859817'
17             '93f2e6a9dc942cf1fcab7edbe9c38fc102cbaf86f8b667b70aad4e8e2d1e2fd3'
18             'd57e0aed8784d2b947983209b6513c81ac593c9936c3d7b809b4cd60d4c28607')
20 prepare() {
21   patch -d $pkgname-$_pkgver -p1 < xsdcxx.patch
22   patch -d $pkgname-$_pkgver/libxsd-frontend -p1 < gcc-11.patch # Fix build with GCC 11
25 build() {
26   cd $pkgname-$_pkgver
27   make CXXFLAGS="${CXXFLAGS} -std=c++14"
30 package() {
31   cd $pkgname-$_pkgver
32   make install_prefix="$pkgdir/usr" install
34   # Fix conflicts with mono
35   mv "$pkgdir"/usr/bin/xsd{,cxx}
36   mv "$pkgdir"/usr/share/man/man1/xsd{,cxx}.1