1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=bash-completion
6 pkgdesc='Programmable completion for the bash shell'
8 url='https://github.com/scop/bash-completion'
11 options=(!emptydirs !makeflags)
12 source=($url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz)
13 validpgpkeys=(A558062B6D5DA1347CD468D52B0AE2C1B09B07CB)
14 sha256sums=('73a8894bad94dee83ab468fa09f628daffd567e8bef1a24277f1e9a0daf911ac')
18 ./configure --prefix=/usr --sysconfdir=/etc
24 make DESTDIR="$pkgdir" install
26 # bash-completion is sourced in /etc/bash.bashrc so that non-bash shell don't source it
27 rm "$pkgdir/etc/profile.d/bash_completion.sh"
29 # remove Slackware's makepkg completion
30 rm "$pkgdir/usr/share/bash-completion/completions/makepkg"