archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kgoldrunner / trunk / PKGBUILD
blobdd6f4d9f39d0b899be1fae99a3e5268a0c8a5734
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kgoldrunner
6 pkgver=22.04.3
7 pkgrel=1
8 pkgdesc='A game of action and puzzle solving'
9 url='https://apps.kde.org/kgoldrunner/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-games)
13 depends=(libkdegames hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('aa9123920fe60dbf01ab584136049b276a0a46abfe548077760b3f48af6c40bd'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build