archrelease: copy trunk to extra-x86_64
[arch-packages.git] / knotifications / repos / extra-x86_64 / PKGBUILD
blob447326e337aad9e9b6f59fb6d0c735f3afe4e5c9
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=knotifications
6 pkgver=5.96.0
7 pkgrel=1
8 pkgdesc='Abstraction for system notifications'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(libcanberra libdbusmenu-qt5 kwindowsystem kconfig kcoreaddons qt5-speech libxtst)
13 makedepends=(extra-cmake-modules qt5-tools qt5-doc doxygen qt5-declarative)
14 optdepends=('qt5-declarative: QML bindings')
15 groups=(kf5)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('12933ae33e511b6a37fb3b0dc896248ffdd2ef007e2fc4dd05757fc8a8c7cb85'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF \
25     -DBUILD_QCH=ON
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build