archrelease: copy trunk to extra-x86_64
[arch-packages.git] / openssh / trunk / PKGBUILD
blob06760780531dbdc5e65cb575e806072fec4a36c6
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
3 # Contributor: Gaetan Bisson <bisson@archlinux.org>
4 # Contributor: Aaron Griffin <aaron@archlinux.org>
5 # Contributor: judd <jvinet@zeroflux.org>
7 pkgname=openssh
8 pkgver=9.0p1
9 pkgrel=1
10 pkgdesc='Premier connectivity tool for remote login with the SSH protocol'
11 url='https://www.openssh.com/portable.html'
12 license=('custom:BSD')
13 arch=('x86_64')
14 depends=('glibc' 'krb5' 'openssl' 'libedit' 'ldns' 'libxcrypt' 'libcrypt.so' 'zlib' 'pam')
15 makedepends=('linux-headers' 'libfido2')
16 optdepends=('xorg-xauth: X11 forwarding'
17             'x11-ssh-askpass: input passphrase in X'
18             'libfido2: FIDO/U2F support')
19 options=('debug')
20 validpgpkeys=('7168B983815A5EEF59A4ADFD2A3F414E736060BA')
21 #source=("git://anongit.mindrot.org/openssh.git?signed#tag=V_8_2_P1"
22 source=("https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"{,.asc}
23         'sshdgenkeys.service'
24         'sshd.service'
25         'sshd.conf'
26         'sshd.pam')
27 sha1sums=('06dd658874dcd22d66311cf5999bd56c614de509'
28           'SKIP'
29           'caaa801da59a5d14c0c29c43e9de5fef281ea03e'
30           '8640ac6593602e74a863263223e92ab5c4711588'
31           'c9b2e4ce259cd62ddb00364d3ee6f00a8bf2d05f'
32           'd93dca5ebda4610ff7647187f8928a3de28703f3')
33 sha256sums=('03974302161e9ecce32153cfa10012f1e65c8f3750f573a73ab1befd5972a28a'
34             'SKIP'
35             '4031577db6416fcbaacf8a26a024ecd3939e5c10fe6a86ee3f0eea5093d533b7'
36             'e40f8b7c8e5e2ecf3084b3511a6c36d5b5c9f9e61f2bb13e3726c71dc7d4fbc7'
37             '4effac1186cc62617f44385415103021f72f674f8b8e26447fc1139c670090f6'
38             '64576021515c0a98b0aaf0a0ae02e0f5ebe8ee525b1e647ab68f369f81ecd846')
39 b2sums=('49724a400951964d659d136908657940f79e150056728cc4dadf8ff8652a832f7fd46eebb47b15085e57fca4b00c77d1ec4dd1b056ea2bbcee89f54a121ed5e2'
40         'SKIP'
41         '62f89107d3648a359b0307497a9f105d7ff1dddddb38a64afe3261000b5db494a5530e4b60a9aa1d7be4413599e54b72e2f53f0de8c1ff263a46a70bc5695c29'
42         '07ad5c7fb557411a6646ff6830bc9d564c07cbddc4ce819641d31c05dbdf677bfd8a99907cf529a7ee383b8c250936a6423f4b4b97ba0f1c14f627bbd629bd4e'
43         '27571f728c3c10834a81652f3917188436474b588f8b047462e44b6c7a424f60d06ce8cb74839b691870177d7261592207d7f35d4ae6c79af87d6a7ea156d395'
44         '557d015bca7008ce824111f235da67b7e0051a693aaab666e97b78e753ed7928b72274af03d7fde12033986b733d5f996faf2a4feb6ecf53f39accae31334930')
46 backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
48 install=install
50 # prepare() {
51 #       cd "${srcdir}/${pkgname}-${pkgver}"
53 #       patch goes here
55 #       autoreconf
56 # }
58 build() {
59         cd "${srcdir}/${pkgname}-${pkgver}"
61         ./configure \
62                 --prefix=/usr \
63                 --sbindir=/usr/bin \
64                 --libexecdir=/usr/lib/ssh \
65                 --sysconfdir=/etc/ssh \
66                 --disable-strip \
67                 --with-ldns \
68                 --with-libedit \
69                 --with-security-key-builtin \
70                 --with-ssl-engine \
71                 --with-pam \
72                 --with-privsep-user=nobody \
73                 --with-kerberos5=/usr \
74                 --with-xauth=/usr/bin/xauth \
75                 --with-md5-passwords \
76                 --with-pid-dir=/run \
77                 --with-default-path='/usr/local/sbin:/usr/local/bin:/usr/bin' \
79         make
82 check() {
83         cd "${srcdir}/${pkgname}-${pkgver}"
85         # Tests require openssh to be already installed system-wide,
86         # also connectivity tests will fail under makechrootpkg since
87         # it runs as nobody which has /bin/false as login shell.
89         if [[ -e /usr/bin/scp && ! -e /.arch-chroot ]]; then
90                 make tests
91         fi
94 package() {
95         cd "${srcdir}/${pkgname}-${pkgver}"
97         make DESTDIR="${pkgdir}" install
99         ln -sf ssh.1.gz "${pkgdir}"/usr/share/man/man1/slogin.1.gz
100         install -Dm644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
102         install -Dm644 ../sshdgenkeys.service "${pkgdir}"/usr/lib/systemd/system/sshdgenkeys.service
103         install -Dm644 ../sshd.service "${pkgdir}"/usr/lib/systemd/system/sshd.service
104         install -Dm644 ../sshd.conf "${pkgdir}"/usr/lib/tmpfiles.d/sshd.conf
105         install -Dm644 ../sshd.pam "${pkgdir}"/etc/pam.d/sshd
107         install -Dm755 contrib/findssl.sh "${pkgdir}"/usr/bin/findssl.sh
108         install -Dm755 contrib/ssh-copy-id "${pkgdir}"/usr/bin/ssh-copy-id
109         install -Dm644 contrib/ssh-copy-id.1 "${pkgdir}"/usr/share/man/man1/ssh-copy-id.1
111         sed \
112                 -e '/^#KbdInteractiveAuthentication yes$/c KbdInteractiveAuthentication no' \
113                 -e '/^#PrintMotd yes$/c PrintMotd no # pam does that' \
114                 -e '/^#UsePAM no$/c UsePAM yes' \
115                 -i "${pkgdir}"/etc/ssh/sshd_config