archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-datavis3d / repos / kde-unstable-x86_64 / PKGBUILD
blobe8b38296da76a34c6996bfa8a2f7838ebe883223
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-datavis3d
5 _qtver=6.4.0-beta2
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Qt6 Data Visualization module'
12 depends=(qt6-base)
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
15 groups=(qt6)
16 options=(debug)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('5e239c042c1e238c2f58f7405455b49aa438a577cc52c858358417c434a8abeb')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname