archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libcdio / repos / extra-x86_64 / PKGBUILD
blobafaf75f3b9e1fecfcda58cdcb6e14c1f8bfbf748
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: damir <damir@archlinux.org>
4 pkgname=libcdio
5 pkgver=2.1.0
6 pkgrel=2
7 pkgdesc="GNU Compact Disc Input and Control Library"
8 url="https://www.gnu.org/software/libcdio/"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(libcddb ncurses gcc-libs)
12 source=(https://ftp.gnu.org/gnu/libcdio/$pkgname-$pkgver.tar.bz2{,.sig})
13 sha256sums=('8550e9589dbd594bfac93b81ecf129b1dc9d0d51e90f9696f1b2f9b2af32712b'
14             'SKIP')
15 validpgpkeys=('DAA63BC2582034A02B923D521A8DE5008275EC21') # R. Bernstein
17 prepare() {
18   cd $pkgname-$pkgver
19   autoreconf -fi
22 build() {
23   cd $pkgname-$pkgver
24   ./configure --prefix=/usr --disable-vcd-info --enable-cpp-progs --disable-static
25   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
26   make
29 check() {
30   cd $pkgname-$pkgver
31   make -C test check
34 package() {
35   cd $pkgname-$pkgver
36   make DESTDIR="$pkgdir" install
38   sed -e "/define CDIO_LIBCDIO_SOURCE_PATH/s|.*|/* #undef CDIO_LIBCDIO_SOURCE_PATH */|" \
39       -i "$pkgdir/usr/include/cdio/cdio_config.h"