archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-shadertools / kde-unstable / PKGBUILD
blobc76ecaf20ba7f18caf943da4f9509e262b61f63e
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-shadertools
6 _qtver=6.4.0-beta1
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3)
12 pkgdesc='Provides functionality for the shader pipeline that allows Qt Quick to operate on Vulkan, Metal, and Direct3D, in addition to OpenGL'
13 depends=(qt6-base)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 options=(debug)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('a196e2ebf8491d5606eac91065df539309e6f4deb1d5cbd1cf6ad3acfe83a0fd')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname