1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-shadertools
10 url='https://www.qt.io'
12 pkgdesc='Provides functionality for the shader pipeline that allows Qt Quick to operate on Vulkan, Metal, and Direct3D, in addition to OpenGL'
14 makedepends=(cmake ninja)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('a196e2ebf8491d5606eac91065df539309e6f4deb1d5cbd1cf6ad3acfe83a0fd')
22 cmake -B build -S $_pkgfn -G Ninja \
23 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
28 DESTDIR="$pkgdir" cmake --install build
30 install -d "$pkgdir"/usr/share/licenses
31 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname