archrelease: copy trunk to extra-x86_64
[arch-packages.git] / yelp / trunk / PKGBUILD
blob21ffbdcc3ef6fd8d272e51b5cdd3a1f6e87b811a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=yelp
5 pkgver=42.1
6 pkgrel=2
7 pkgdesc="Get help with GNOME"
8 url="https://wiki.gnome.org/Apps/Yelp"
9 license=(GPL)
10 arch=(x86_64)
11 depends=(webkit2gtk-4.1 yelp-xsl libxslt xz bzip2 libhandy)
12 makedepends=(itstool autoconf-archive git appstream-glib)
13 groups=(gnome)
14 options=(debug)
15 _commit=d16114cb46e4de07e6d1c0511ef8d6e1921e023e  # tags/42.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/yelp.git#commit=$_commit"
17         no-gtk-doc.diff)
18 sha256sums=('SKIP'
19             'adbc49d20ee3055cd38f2ec739b2de7b1710e306cfae09eafc5fe57e63d84e40')
21 pkgver() {
22   cd yelp
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd yelp
29   # Remove vestiges of docs build to allow building without gtk-doc
30   git apply -3 ../no-gtk-doc.diff
32   NOCONFIGURE=1 ./autogen.sh
35 build() {
36   cd yelp
37   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
38     --disable-static --enable-compile-warnings=minimum
39   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
40   make
43 package() {
44   cd yelp
45   make DESTDIR="$pkgdir" install