sbcl rebuild
[arch-packages.git] / cairo / repos / extra-x86_64 / PKGBUILD
blobcb6f5b7f7a763371da624703e53ea865cbd21217
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Brice Carpentier <brice@daknet.org>
5 pkgname=cairo
6 pkgver=1.17.6
7 pkgrel=2
8 pkgdesc="2D graphics library with support for multiple output devices"
9 url="https://cairographics.org/"
10 arch=(x86_64)
11 license=(LGPL MPL)
12 depends=(lzo zlib libpng fontconfig freetype2 libx11 libxext libxrender libxcb
13          glib2 pixman)
14 makedepends=(valgrind git meson gtk-doc)
15 options=(debug)
16 _commit=b43e7c6f3cf7855e16170a06d3a9c7234c60ca94  # tags/1.17.6^0
17 source=("git+https://gitlab.freedesktop.org/cairo/cairo.git#commit=$_commit"
18         0001-Fix-type1-subset-indexing.patch)
19 sha256sums=('SKIP'
20             '296be3c73638314bea08fa51b5f1650ea0a2aab2a037ea55e41c319d64ca4c3c')
22 pkgver() {
23   cd cairo
24   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd cairo
30   # FS#74354
31   patch -Np1 -i ../0001-Fix-type1-subset-indexing.patch
34 build() {
35   arch-meson cairo build \
36     -D spectre=disabled \
37     -D tee=enabled \
38     -D tests=disabled \
39     -D symbol-lookup=disabled \
40     -D gtk_doc=true
41   meson compile -C build
44 package() {
45   meson install -C build --destdir "$pkgdir"