sbcl rebuild
[arch-packages.git] / flatpak / repos / testing-x86_64 / PKGBUILD
blob15e8db84ec275aa97c183344dfa4d6de759b74d2
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
5 pkgname=flatpak
6 _commit=488038eed44c7edf334d1e28085975d96ce2bdcc  # tags/1.14.0^0
7 pkgver=1.14.0
8 pkgrel=3
9 epoch=1
10 pkgdesc="Linux application sandboxing and distribution framework (formerly xdg-app)"
11 url="https://flatpak.org"
12 arch=(x86_64)
13 license=(LGPL)
14 depends=(dbus glib2 curl polkit libxau ostree json-glib libseccomp libarchive
15          python bubblewrap appstream xdg-dbus-proxy systemd fuse3 libmalcontent)
16 makedepends=(gobject-introspection gtk-doc git docbook-xsl xmlto
17              python-pyparsing)
18 checkdepends=(valgrind socat)
19 options=(debug)
20 source=(
21   "git+https://github.com/flatpak/flatpak#commit=$_commit"
22   git+https://gitlab.gnome.org/GNOME/libglnx.git
23   git+https://github.com/projectatomic/bubblewrap
24   git+https://github.com/flatpak/xdg-dbus-proxy
25   git+https://gitlab.gnome.org/alexl/variant-schema-compiler.git
26   https://dl.flathub.org/repo/flathub.flatpakrepo
27   fusermount3.diff
28   flatpak-bindir.sh
30 sha256sums=('SKIP'
31             'SKIP'
32             'SKIP'
33             'SKIP'
34             'SKIP'
35             '3371dd250e61d9e1633630073fefda153cd4426f72f4afa0c3373ae2e8fea03a'
36             '23e01650d60222082ffb67a16d3ea033192cc9e6932027cf0ea0c55ea17863af'
37             '1824cb4eb1cc88702cb2b9f1c55b6dfdf20fca5eab83f6e8e532099281328745')
39 pkgver() {
40   cd flatpak
41   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
44 prepare() {
45   cd flatpak
47   # Support fuse3
48   # https://bugs.archlinux.org/task/75623
49   git apply -3 ../fusermount3.diff
51   git submodule init
52   git submodule set-url libglnx "$srcdir/libglnx"
53   git submodule set-url bubblewrap "$srcdir/bubblewrap"
54   git submodule set-url dbus-proxy "$srcdir/xdg-dbus-proxy"
55   git submodule set-url variant-schema-compiler "$srcdir/variant-schema-compiler"
56   git -c protocol.file.allow=always submodule update
58   NOCONFIGURE=1 ./autogen.sh
61 build() {
62   local configure_options=(
63     --prefix=/usr
64     --sysconfdir=/etc
65     --localstatedir=/var
66     --sbindir=/usr/bin
67     --libexecdir=/usr/lib
68     --disable-static
69     --enable-docbook-docs
70     --enable-gtk-doc
71     --with-curl
72     --with-dbus-config-dir=/usr/share/dbus-1/system.d
73     --with-system-bubblewrap
74     --with-system-dbus-proxy
75   )
77   cd flatpak
78   ./configure "${configure_options[@]}"
79   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
80   make
83 check() {
84   cd flatpak
85   make -k check
88 package() {
89   depends+=(xdg-desktop-portal libostree-1.so)
90   provides=(libflatpak.so)
92   make -C flatpak DESTDIR="$pkgdir" install
94   install -Dt "$pkgdir/etc/profile.d" -m644 flatpak-bindir.sh
95   install -Dt "$pkgdir/etc/flatpak/remotes.d" flathub.flatpakrepo
97   # Fixup mode to match polkit
98   install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"