1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
6 _commit=488038eed44c7edf334d1e28085975d96ce2bdcc # tags/1.14.0^0
10 pkgdesc="Linux application sandboxing and distribution framework (formerly xdg-app)"
11 url="https://flatpak.org"
14 depends=(dbus glib2 curl polkit libxau ostree json-glib libseccomp libarchive
15 python bubblewrap appstream xdg-dbus-proxy systemd fuse3 libmalcontent)
16 makedepends=(gobject-introspection gtk-doc git docbook-xsl xmlto
18 checkdepends=(valgrind socat)
21 "git+https://github.com/flatpak/flatpak#commit=$_commit"
22 git+https://gitlab.gnome.org/GNOME/libglnx.git
23 git+https://github.com/projectatomic/bubblewrap
24 git+https://github.com/flatpak/xdg-dbus-proxy
25 git+https://gitlab.gnome.org/alexl/variant-schema-compiler.git
26 https://dl.flathub.org/repo/flathub.flatpakrepo
35 '3371dd250e61d9e1633630073fefda153cd4426f72f4afa0c3373ae2e8fea03a'
36 '23e01650d60222082ffb67a16d3ea033192cc9e6932027cf0ea0c55ea17863af'
37 '1824cb4eb1cc88702cb2b9f1c55b6dfdf20fca5eab83f6e8e532099281328745')
41 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
48 # https://bugs.archlinux.org/task/75623
49 git apply -3 ../fusermount3.diff
52 git submodule set-url libglnx "$srcdir/libglnx"
53 git submodule set-url bubblewrap "$srcdir/bubblewrap"
54 git submodule set-url dbus-proxy "$srcdir/xdg-dbus-proxy"
55 git submodule set-url variant-schema-compiler "$srcdir/variant-schema-compiler"
56 git -c protocol.file.allow=always submodule update
58 NOCONFIGURE=1 ./autogen.sh
62 local configure_options=(
72 --with-dbus-config-dir=/usr/share/dbus-1/system.d
73 --with-system-bubblewrap
74 --with-system-dbus-proxy
78 ./configure "${configure_options[@]}"
79 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
89 depends+=(xdg-desktop-portal libostree-1.so)
90 provides=(libflatpak.so)
92 make -C flatpak DESTDIR="$pkgdir" install
94 install -Dt "$pkgdir/etc/profile.d" -m644 flatpak-bindir.sh
95 install -Dt "$pkgdir/etc/flatpak/remotes.d" flathub.flatpakrepo
97 # Fixup mode to match polkit
98 install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"