sbcl rebuild
[arch-packages.git] / gnome-screenshot / repos / extra-x86_64 / PKGBUILD
blob573ae89d1103c249f76d6a37cf0731acadb21eb6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-screenshot
5 pkgver=41.0+r25+g45f08f0
6 pkgrel=1
7 pkgdesc="Take pictures of your screen"
8 url="https://gitlab.gnome.org/GNOME/gnome-screenshot"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(gtk3 libhandy)
12 makedepends=(git meson appstream-glib)
13 options=(debug)
14 _commit=45f08f0b91a7b2aa589c9b3add671e144207e37a  # master
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-screenshot.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
40 # vim:set sw=2 et: