upgpkg: ocaml 5.0.0-1
[arch-packages.git] / d-spy / repos / extra-x86_64 / PKGBUILD
blob2999f63fc5489ff2cb4a9ef66b30622d079c68ab
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=d-spy
4 pkgver=1.6.0
5 pkgrel=2
6 pkgdesc="D-Bus debugger for GNOME"
7 url="https://gitlab.gnome.org/GNOME/d-spy"
8 arch=(x86_64)
9 license=(
10   GPL3
11   LGPL3
13 depends=(
14   gtk4
15   libadwaita
17 makedepends=(
18   git
19   meson
21 provides=(libdspy-1.so)
22 groups=(gnome-extra)
23 _commit=9268a01e3fcc7d15c617f4bb57f2fe213bb4d078  # tags/1.6.0^0
24 source=("git+https://gitlab.gnome.org/GNOME/d-spy.git#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd d-spy
29   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 build() {
33   arch-meson d-spy build
34   meson compile -C build
37 check() {
38   meson test -C build --print-errorlogs
41 package() {
42   meson install -C build --destdir "$pkgdir"
45 # vim:set sw=2 sts=-1 et: