upgpkg: ocaml 5.0.0-1
[arch-packages.git] / layer-shell-qt / trunk / PKGBUILD
blobed271d606c74cea0b36e701be03744f0d889d6f9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=layer-shell-qt
4 pkgver=5.27.5
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='Qt component to allow applications to make use of the Wayland wl-layer-shell protocol'
8 arch=(x86_64)
9 url='https://kde.org/plasma-desktop/'
10 license=(GPL LGPL)
11 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
12 depends=(qt5-wayland)
13 makedepends=(extra-cmake-modules wayland-protocols)
14 groups=(plasma)
15 sha256sums=('ccdf6aa579f0437f3bad377ac35268dfab36f6816227c03bae0591301c8d1d21'
16             'SKIP')
17 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
18               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
19               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
20               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
22 build() {
23   cmake -B build -S $pkgname-$pkgver
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build