upgpkg: ocaml 5.0.0-1
[arch-packages.git] / xorg-xfd / trunk / PKGBUILD
blob63400ccd39d4362ceea93319aae3e3793c12dd22
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-xfd
5 pkgver=1.1.4
6 pkgrel=1
7 pkgdesc="Displays all the characters in a font using either the X11 core protocol or libXft2"
8 arch=(x86_64)
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libxaw' 'fontconfig' 'libxft' 'libxrender' 'libxmu' 'libxkbfile')
12 makedepends=('xorg-util-macros')
13 source=(https://xorg.freedesktop.org/archive/individual/app/xfd-${pkgver}.tar.xz{,.sig})
14 sha512sums=('fa1f8a7b5d89be20fb2b1e3e0e8f4d7f9463e91fd385d21e1403a398c2e263112043b568417c420c5ee33bec60e06658498dd55df6d7ac19da3af0844f932209'
15             'SKIP')
16 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
18 build() {
19   cd xfd-${pkgver}
20   ./configure --prefix=/usr
21   make
24 package() {
25   cd xfd-${pkgver}
26   make DESTDIR="${pkgdir}" install
27   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
28   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"