db-move: moved gnome-clocks from [testing] to [extra] (x86_64)
[arch-packages.git] / fribidi / trunk / PKGBUILD
bloba08b74f6121a9b185e097b2cee6c9f22357013d1
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: Nezmer <Nezmer@gmail.com>
5 pkgname=fribidi
6 pkgver=1.0.12
7 pkgrel=1
8 pkgdesc="A Free Implementation of the Unicode Bidirectional Algorithm"
9 url="https://github.com/fribidi/fribidi/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glibc)
13 makedepends=(git meson)
14 provides=(libfribidi.so)
15 _commit=6428d8469e536bcbb6e12c7b79ba6659371c435a  # tags/v1.0.12^0
16 source=("git+https://github.com/fribidi/fribidi#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd fribidi
21   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd fribidi
28 build() {
29   arch-meson fribidi build \
30     -D docs=false
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 et: