db-move: moved gnome-clocks from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-nettool / trunk / PKGBUILD
blobe07807172839143f857484825900b42db24a0e69
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Kritoke <kritoke@nospam.gmail.com>
5 pkgname=gnome-nettool
6 pkgver=42.0
7 pkgrel=2
8 pkgdesc="Graphical interface for various networking tools"
9 url="https://gitlab.gnome.org/GNOME/gnome-nettool"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(
13   gtk3
14   iputils
15   libgtop
16   whois
18 makedepends=(
19   bind
20   git
21   meson
22   net-tools
23   nmap
24   yelp-tools
26 optdepends=(
27   'bind: DNS lookup'
28   'net-tools: Network statistics'
29   'nmap: Port scanning'
31 _commit=5748c0fa632c9caad9e46377ca1aa330dec4b757  # tags/gnome-nettool-42-0^0
32 source=(
33   "git+https://gitlab.gnome.org/GNOME/gnome-nettool.git#commit=$_commit"
34   fix-build.diff
36 b2sums=('SKIP'
37         '1da17fa0249252842a4cc4c68d00f67b5f085642ae10e6db68708df3cf1fa4b88c9039b2deff2e70ffadf8474da85a33b50bf1a1b639bf12dda05e696f239e72')
39 pkgver() {
40   cd $pkgname
41   git describe --tags | sed 's/^gnome-nettool-//;s/-/./;s/[^-]*-g/r&/;s/-/+/g'
44 prepare() {
45   cd $pkgname
47   # Fix build with recent Meson
48   git apply -3 ../fix-build.diff
51 build() {
52   arch-meson $pkgname build
53   meson compile -C build
56 check() {
57   meson test -C build --print-errorlogs
60 package() {
61   meson install -C build --destdir "$pkgdir"
64 # vim set:sw=2 sts=-1 et: