db-move: moved gnome-clocks from [testing] to [extra] (x86_64)
[arch-packages.git] / grilo / repos / testing-x86_64 / PKGBUILD
blob6b697020cf3adc8bbd72d91e8903abdde2038e4b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=grilo
4 pkgver=0.3.15
5 pkgrel=3
6 pkgdesc="Framework that provides access to various sources of multimedia content"
7 url="https://wiki.gnome.org/Projects/Grilo"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(
11   liboauth
12   libsoup3
13   libxml2
14   totem-pl-parser
16 makedepends=(
17   git
18   gobject-introspection
19   gtk-doc
20   gtk3
21   meson
22   vala
24 optdepends=(
25   'grilo-plugins: Plugins for grilo'
26   'gtk3: Test UI'
28 provides=(libgr{ilo,lnet,lpls}-0.3.so)
29 _commit=14a4a66d92b78d7db6e872cf09db40fbfb6c470d  # tags/grilo-0.3.15^0
30 source=("git+https://gitlab.gnome.org/GNOME/grilo.git#commit=$_commit")
31 b2sums=('SKIP')
33 pkgver() {
34   cd grilo
35   git describe --tags | sed 's/^grilo-//;s/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd grilo
42 build() {
43   arch-meson grilo build
44   meson compile -C build
47 check() {
48   meson test -C build --print-errorlogs
51 package() {
52   meson install -C build --destdir "$pkgdir"
55 # vim:set sw=2 sts=-1 et: