db-move: moved gnome-calendar from [testing] to [extra] (x86_64)
[arch-packages.git] / dialog / trunk / PKGBUILD
blobb8a99a7699745c66c3409dadd4a681ed39be7451
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: Andreas Radke <andyrtr@archlinux.org>
6 pkgname=dialog
7 pkgver=1.3_20230209
8 pkgrel=1
9 epoch=1
10 pkgdesc="A tool to display dialog boxes from shell scripts"
11 arch=('x86_64')
12 url="https://invisible-island.net/dialog/"
13 license=('LGPL2.1')
14 depends=('sh' 'ncurses')
15 provides=('libdialog.so')
16 source=(https://invisible-mirror.net/archives/$pkgname/$pkgname-${pkgver/_/-}.tgz{,.asc})
17 sha256sums=('0c26282305264be2217f335f3798f48b1dce3cf12c5a076bf231cadf77a6d6a8'
18             'SKIP')
19 validpgpkeys=('19882D92DDA4C400C22C0D56CC2AF4472167BE03') # Thomas E. Dickey (self-signed w/o SHA1) <dickey@invisible-island.net>
21 build() {
22   cd "$srcdir/$pkgname-${pkgver/_/-}"
24   ./configure \
25     --prefix=/usr \
26     --enable-nls \
27     --with-libtool \
28     --with-ncursesw
29   make
32 package() {
33   cd "$srcdir/$pkgname-${pkgver/_/-}"
34   make DESTDIR="$pkgdir" install-full
37 # vim:set ts=2 sw=2 et: