db-move: moved gnome-calendar from [testing] to [extra] (x86_64)
[arch-packages.git] / lightsoff / trunk / PKGBUILD
blob4b0b45510580931f0b2c3c029ee5d14ba794391d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=lightsoff
5 pkgver=40.0.1
6 pkgrel=1
7 pkgdesc="Turn off all the lights"
8 url="https://wiki.gnome.org/Apps/Lightsoff"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg)
12 makedepends=(yelp-tools vala git meson)
13 groups=(gnome-extra)
14 _commit=ca05a49ff447a6d7fdfadd1921288e2d720f5c09  # tags/40.0.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/lightsoff.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build