1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
6 pkgdesc='A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics'
7 url='https://www.openexr.com/'
11 optdepends=('python: python bindings' 'boost-libs: python bindings')
12 makedepends=(cmake python boost)
13 source=(https://github.com/AcademySoftwareFoundation/Imath/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('0bf7ec51162c4d17a4c5b850fb3f6f7a195cff9fa71f4da7735f74d7b5124320')
17 cmake -B build -S Imath-$pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr \
24 DESTDIR="$pkgdir" cmake --install build
25 install -Dm644 Imath-$pkgver/LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname