1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: Tobias Kieslich <tobias@justdreams.de>
3 # Contributor: tobias <tobias@archlinux.org>
7 _tag='3bf5ae0d25c673abe152dedf4789a2d6f0cc60ff' # git rev-parse INKSCAPE_${pkgver/./_}
9 pkgdesc='Professional vector graphics editor'
10 url='https://inkscape.org/'
11 license=('GPL' 'LGPL')
13 makedepends=('cmake' 'boost' 'git')
37 'gvfs: import clip art'
38 'pstoedit: latex formulas'
39 'python-lxml: some extensions'
40 'python-numpy: some extensions'
41 'scour: optimized SVG output, some extensions'
42 'texlive-core: latex formulas'
45 #source=("https://media.inkscape.org/dl/resources/file/${pkgname}-${pkgver}.tar.bz2")
46 source=("git+https://gitlab.com/inkscape/inkscape.git#tag=${_tag}"
47 poppler-21.11.0.patch)
49 '76bd1cc64ce7abef0f1758a7f05d9ca9e2cf44506318fb8ae9da029543aa1762')
56 # https://gitlab.com/inkscape/inkscape/-/merge_requests/3622
57 patch -Np1 -i ../poppler-21.11.0.patch
62 export PKG_CONFIG_PATH='/usr/lib/imagemagick6/pkgconfig'
63 cmake -H${pkgname} -Bbuild \
64 -DCMAKE_BUILD_TYPE=Release \
65 -DCMAKE_INSTALL_PREFIX:PATH=/usr \
72 DESTDIR="${pkgdir}" cmake --build build --target install