archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kaccounts-integration / trunk / PKGBUILD
blobff01f864494c19901449509ea432fe2070a50484
1 # Maintainer: Antonio Rojas <arojas@archlinux.org> 
3 pkgname=kaccounts-integration
4 pkgver=21.12.0
5 pkgrel=1
6 pkgdesc='Small system to administer web accounts for the sites and services across the KDE desktop, including: Google, Facebook, Owncloud, IMAP, 
7 Jabber and others'
8 arch=(x86_64)
9 url='https://www.kde.org/'
10 license=(GPL)
11 depends=(kcmutils signon-kwallet-extension signon-plugin-oauth2 signon-ui)
12 makedepends=(extra-cmake-modules kdoctools)
13 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('c71237afb05be595d4ef308694476d1b9f491637f98decfa7023b22f5fb08a36'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build