archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libvisual-plugins / trunk / PKGBUILD
blob92355e7e188f60f8b190150481369a38fac2f836
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: damir <damir@archlinux.org>
4 pkgname=libvisual-plugins
5 pkgver=0.4.0
6 pkgrel=11
7 pkgdesc="plugins for libvisual"
8 arch=("x86_64")
9 license=('GPL')
10 url="https://sourceforge.net/projects/libvisual/"
11 depends=('libvisual' 'glu' 'alsa-lib' 'jack' 'gdk-pixbuf2')
12 makedepends=('mesa' 'gtk2')
13 source=(https://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.bz2
14         02_64-bit_JESS_fix.patch
15         03_build_against_gl_fixes.patch
16         04_lv_analyzer_build_fix.patch
17         05_fix_po.patch
18         050_all_automagic.patch
19         60_no-const-vispluginfo-in-nastyfft.patch)
20 sha256sums=('518eef40a8a41946a0c2c0d59ede40d53ba7c142873af71aa4d2d8f297396601'
21             '49efe3991dd90c712916af06e4c1104bfc016f3004f77daaaba2be4a92eee251'
22             'c9e673b36c125fda5015fcb6462a69e5ab3ff55828342c8b8483e76f84853ef8'
23             '083d3e16aacaf7853de713d604a1b2a06bc5f739d9c94a7bfe5099bf27da8670'
24             'be20595c8092dee1c07184a2fa4eb924decf9de752ee973d997688d192e0e346'
25             'b85bc97614d75f76f8f7fa9a0f6a1292813727229e615556f426b3386af625b5'
26             '4906fd72097cb33fc4b88b89384cbb00685fee3de29d321178f92e8fb9610856')
28 build() {
29   cd "${srcdir}/${pkgname}-${pkgver}"
30   patch -Np1 -i "${srcdir}/02_64-bit_JESS_fix.patch"
31   patch -Np1 -i "${srcdir}/03_build_against_gl_fixes.patch"
32   patch -Np1 -i "${srcdir}/04_lv_analyzer_build_fix.patch"
33   patch -Np0 -i "${srcdir}/050_all_automagic.patch"
34   patch -Np1 -i "${srcdir}/60_no-const-vispluginfo-in-nastyfft.patch"
36   autoreconf -fi
37   # Apply later as autoreconf overwrites po/Makefile.in.in
38   patch -Np1 -i "${srcdir}/05_fix_po.patch"
40   ./configure --prefix=/usr \
41       --disable-gstreamer-plugin \
42       --disable-gforce \
43       --disable-esd
44   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
45   make
48 package() {
49   cd "${srcdir}/${pkgname}-${pkgver}"
50   make DESTDIR="${pkgdir}" install