archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-evdev / trunk / PKGBUILD
blobbcc969a99512b50791d60355ccf63d95fa647643
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=python-evdev
4 pkgver=1.4.0
5 pkgrel=3
6 pkgdesc="Python bindings for the Linux input subsystem"
7 url="https://python-evdev.readthedocs.io/en/latest/"
8 arch=(x86_64)
9 license=(BSD)
10 depends=(python)
11 makedepends=(git)
12 _commit=5adc2abf1ec8a02c05c80cb1b3e34ba1d4237803  # tags/v1.4.0^0
13 source=("git+https://github.com/gvalkov/python-evdev#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/-/+/g'
21 build() {
22   cd $pkgname
23   python setup.py build
26 package() {
27   cd $pkgname
28   python setup.py install --root="$pkgdir" --optimize=1 --skip-build
29   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE