archrelease: copy trunk to testing-x86_64
[arch-packages.git] / empathy / trunk / PKGBUILD
blobf72f104882239bad4cf9df1c6bc19fa70b27d254
1 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 pkgname=empathy
4 pkgver=3.25.90+34+g78f4d4fda
5 pkgrel=3
6 pkgdesc="A GNOME instant messaging client using the Telepathy framework"
7 url="https://wiki.gnome.org/Apps/Empathy"
8 arch=(x86_64)
9 license=(GPL2)
10 depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
11          telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control geoclue2
12          geocode-glib cheese libchamplain libgudev)
13 makedepends=(intltool itstool docbook-xsl python gnome-common git)
14 optdepends=('telepathy-gabble: XMPP/Jabber support'
15             'telepathy-idle: IRC support'
16             'telepathy-salut: Link-local XMPP support'
17             'telepathy-haze: libpurple support')
18 _commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9  # master
19 source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
20         "git+https://git.gnome.org/browse/telepathy-account-widgets"
21         enchant-2.patch)
22 sha256sums=('SKIP'
23             'SKIP'
24             'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/^EMPATHY_//;s/_/./g;s/-/+/g'
31 prepare() {
32   cd $pkgname
34   git submodule init
35   git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
36   git submodule update
38   patch -Np1 -i ../enchant-2.patch
40   NOCONFIGURE=1 ./autogen.sh
43 build() {
44   cd $pkgname
45   export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
46   ./configure --prefix=/usr \
47       --sysconfdir=/etc  \
48       --libexecdir=/usr/lib/empathy \
49       --disable-static \
50       --disable-Werror
51   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
52   make
55 package() {
56   cd $pkgname
57   make DESTDIR="$pkgdir" install