1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=flatpak-builder
6 pkgdesc="Tool to build flatpaks from source"
7 url="https://flatpak.org"
10 depends=(flatpak binutils elfutils unzip tar git bzr patch rpmextract cpio
12 makedepends=(gobject-introspection git docbook-xsl xmlto)
13 checkdepends=(valgrind)
14 replaces=('flatpak<0.9.10')
15 _commit=4e9fb6a3e6c405f10797f12cc5c8c0a6ce99282d # tags/1.2.2^0
16 source=("git+https://github.com/flatpak/flatpak-builder#commit=$_commit"
17 "git+https://gitlab.gnome.org/GNOME/libglnx.git"
18 "git+https://sourceware.org/git/debugedit.git")
25 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 git submodule set-url libglnx "$srcdir/libglnx"
33 git submodule set-url debugedit "$srcdir/debugedit"
36 # https://github.com/flatpak/flatpak/issues/267
37 sed -i '/locale\/C\./d' tests/make-test-runtime.sh
39 NOCONFIGURE=1 ./autogen.sh
48 --localstatedir=/var \
50 --libexecdir=/usr/lib \
54 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
66 make DESTDIR="$pkgdir" install