archrelease: copy trunk to testing-x86_64
[arch-packages.git] / flatpak-builder / trunk / PKGBUILD
blobce63a8d86ecb3bb34ccc0899ff75b7fb1cf3e46a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=flatpak-builder
4 pkgver=1.2.2
5 pkgrel=1
6 pkgdesc="Tool to build flatpaks from source"
7 url="https://flatpak.org"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(flatpak binutils elfutils unzip tar git bzr patch rpmextract cpio
11          appstream-glib fuse2)
12 makedepends=(gobject-introspection git docbook-xsl xmlto)
13 checkdepends=(valgrind)
14 replaces=('flatpak<0.9.10')
15 _commit=4e9fb6a3e6c405f10797f12cc5c8c0a6ce99282d  # tags/1.2.2^0
16 source=("git+https://github.com/flatpak/flatpak-builder#commit=$_commit"
17         "git+https://gitlab.gnome.org/GNOME/libglnx.git"
18         "git+https://sourceware.org/git/debugedit.git")
19 sha256sums=('SKIP'
20             'SKIP'
21             'SKIP')
23 pkgver() {
24   cd $pkgname
25   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
28 prepare() {
29   cd $pkgname
31   git submodule init
32   git submodule set-url libglnx "$srcdir/libglnx"
33   git submodule set-url debugedit "$srcdir/debugedit"
34   git submodule update
36   # https://github.com/flatpak/flatpak/issues/267
37   sed -i '/locale\/C\./d' tests/make-test-runtime.sh
39   NOCONFIGURE=1 ./autogen.sh
42 build() {
43   cd $pkgname
45   ./configure \
46     --prefix=/usr \
47     --sysconfdir=/etc \
48     --localstatedir=/var \
49     --sbindir=/usr/bin \
50     --libexecdir=/usr/lib \
51     --disable-static \
52     --with-fuse=2
54   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
56   make
59 check() {
60   cd $pkgname
61   make -k check
64 package() {
65   cd $pkgname
66   make DESTDIR="$pkgdir" install