archrelease: copy trunk to testing-x86_64
[arch-packages.git] / gconf-sharp / trunk / PKGBUILD
bloba20c06ac317cf9249901926069d9b294b52f8516
1 # Maintainer: tobias <tobias@archlinux.org>
3 pkgname=('gconf-sharp')
4 pkgver=2.24.2
5 pkgrel=6
6 arch=(x86_64)
7 license=(LGPL)
8 url="http://gtk-sharp.sourceforge.net"
9 pkgdesc="Mono bindings for GConf"
10 depends=('gtk-sharp-2' 'gconf')
11 source=(https://download.gnome.org/sources/gnome-sharp/2.24/gnome-sharp-${pkgver}.tar.bz2
12         02_fix_pkg-config_paths.patch
13         04_initialize_dbus_glib_threading.patch)
14 md5sums=('3b38f53960c736d4afb8f04204efe98b'
15          'a8c1bf57a384f5fc20a5890f9f1cef5a'
16          '90cd7ea88aaa3011522376153433d115')
18 prepare() {
19   cd gnome-sharp-${pkgver}
20   patch -Np1 -i ../04_initialize_dbus_glib_threading.patch
21   patch -Np1 -i ../02_fix_pkg-config_paths.patch
24 build() {
25   cd gnome-sharp-${pkgver}
26   ./configure --prefix=/usr --sysconfdir=/etc
27   make
30 package() {
31   cd gnome-sharp-${pkgver}
32   make -C gconf/GConf install DESTDIR="${pkgdir}"
33   make -C gconf/tools install DESTDIR="${pkgdir}"