archrelease: copy trunk to testing-x86_64
[arch-packages.git] / gnome-nibbles / repos / extra-x86_64 / PKGBUILD
blob36195e6ea4b1fdd6442ef146116faefda30a151d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-nibbles
5 pkgver=3.38.2
6 pkgrel=1
7 pkgdesc="Guide a worm around a maze"
8 url="https://wiki.gnome.org/Apps/Nibbles"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(clutter-gtk gsound librsvg libgnome-games-support libgee)
12 makedepends=(gobject-introspection yelp-tools appstream-glib vala git meson)
13 groups=(gnome-extra)
14 _commit=ca7d44e7a54a018b95d8eec843a701f1739be21f  # tags/3.38.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-nibbles.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build