archrelease: copy trunk to testing-x86_64
[arch-packages.git] / kdenlive / trunk / PKGBUILD
blob35e0a0f24b9c5657d08a523e19aef46b0f16ec36
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Zuf <kontakt.zuf@gmail.com>
4 # Contributor: Darwin Bautista <djclue917@gmail.com>
5 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
7 pkgname=kdenlive
8 pkgver=22.04.3
9 pkgrel=1
10 pkgdesc='A non-linear video editor for Linux using the MLT video framework'
11 arch=(x86_64)
12 url='https://apps.kde.org/kdenlive/'
13 license=(GPL)
14 groups=(kde-applications kde-multimedia)
15 depends=(qt5-networkauth knewstuff knotifyconfig kfilemetadata purpose mlt breeze-icons frei0r-plugins)
16 makedepends=(extra-cmake-modules kdoctools v4l-utils doxygen qt5-tools)
17 optdepends=('ffmpeg: for FFmpeg plugin'
18             'dvgrab: for firewire capture'
19             'recordmydesktop: for screen capture'
20             'opencv: for motion tracking'
21             'plasma-desktop: theme configuration'
22             'opentimelineio: timeline export/import'
23             'bigsh0t: VR360 effects'
24             'mediainfo: for technical clip information'
25             'noise-suppression-for-voice: noise suppression effect')
26 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
27 sha256sums=('7ee62ff9ed3a9e81552ff48b908976e73b5a78f1c93dfa858317af503c345790'
28             'SKIP')
29 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
30               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
31               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
32 options=(debug)
34 build() {
35   cmake -B build -S $pkgname-$pkgver \
36     -DBUILD_TESTING=OFF \
37     -DBUILD_QCH=ON
38   cmake --build build
41 package() {
42   DESTDIR="$pkgdir" cmake --install build