archrelease: copy trunk to testing-x86_64
[arch-packages.git] / libinih / trunk / PKGBUILD
blobf5ba5999753cd5a650868d09753b170004f42587
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alberto Oporto Ames <otreblain@gmail.com>
4 pkgname=libinih
5 pkgver=55
6 pkgrel=2
7 pkgdesc='A simple .INI file parser written in C'
8 arch=(x86_64)
9 url=https://github.com/benhoyt/inih
10 license=(BSD)
11 depends=(
12   gcc-libs
13   glibc
15 makedepends=(
16   git
17   meson
19 provides=(
20   libinih.so
21   libINIReader.so
23 _tag=f7f69c6cff2681d84bae371130b4a018cb2171e6
24 source=(git+https://github.com/benhoyt/inih.git#tag=${_tag})
25 b2sums=(SKIP)
27 pkgver() {
28   cd inih
29   git describe --tags | sed 's/^r//'
32 build() {
33   arch-meson inih build \
34     -Ddefault_library=shared \
35     -Ddistro_install=true \
36     -Dwith_INIReader=true
37   meson compile -C build
40 package() {
41   DESTDIR="$pkgdir" meson install -C build
42   install -Dm 644 inih/LICENSE.txt -t "${pkgdir}"/usr/share/licenses/libinih/
45 # vim: ts=2 sw=2 et: