1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
4 # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
5 # Note: These are for Arch Linux use ONLY. For your own distribution, please
6 # get your own set of keys. Feel free to contact foutrelis@archlinux.org for
8 _google_default_client_id=413772536636.apps.googleusercontent.com
9 _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
11 pkgbase=libreoffice-still
12 pkgname=('libreoffice-still-sdk' 'libreoffice-still')
18 url="https://www.libreoffice.org/"
19 makedepends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python>=3.7' 'libwpd>=0.9.2' 'libwps'
20 'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl' 'dbus-glib'
21 'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu'
22 'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
23 'libmspub' 'harfbuzz-icu' 'nss' 'hicolor-icon-theme'
24 'desktop-file-utils' 'shared-mime-info' 'gst-plugins-base-libs'
25 'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
26 'gperf' 'gtk3' 'qt5-base' 'plasma-framework' 'cppunit' 'beanshell' 'clucene'
27 'junit' 'libmythes' 'libwpg' 'java-environment=11' 'postgresql-libs' 'mariadb-libs' 'libgl'
28 'bluez-libs' 'gdb' 'doxygen' 'libatomic_ops' 'mdds'
29 'apr' 'serf' 'ttf-liberation' 'ttf-dejavu' 'ttf-carlito' 'libxinerama' 'libpagemaker' 'glm'
30 'libabw' 'libmwaw' 'libe-book' 'coin-or-mp' 'liblangtag' 'liborcus'
31 # 'libexttextcat' 'libcmis' 'gobject-introspection' # 'libfbclient'
32 'libexttextcat' 'gobject-introspection' # 'libfbclient'
33 'libtommath' 'libzmf' 'gpgme' 'xmlsec' 'rxvt-unicode'
34 'libepubgen' 'libfreehand' 'libqxp' 'libstaroffice' 'boost' 'libnumbertext'
35 'libffi' 'box2d' 'git'
37 options=('!lto') # using --enable-lto (for parallel link-time optimization)
38 _mirror="https://download.documentfoundation.org/libreoffice/src/${pkgver}"
39 #_mirror="https://dev-builds.libreoffice.org/pre-releases/src"
40 _additional_source_url="https://dev-www.libreoffice.org/src"
41 _additional_source_url2="https://dev-www.libreoffice.org/extern"
42 source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
43 ${_additional_source_url}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
44 ${_additional_source_url}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip # keep old bundled version, new system version ftbs
45 ${_additional_source_url}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
46 ${_additional_source_url}/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
47 ${_additional_source_url}/language-subtag-registry-2021-03-05.tar.bz2
48 ${_additional_source_url}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
49 ${_additional_source_url}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
50 ${_additional_source_url}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
51 ${_additional_source_url}/pdfium-4500.tar.bz2
52 ${_additional_source_url}/dtoa-20180411.tgz
53 ${_additional_source_url}/lxml-4.1.1.tgz
54 ${_additional_source_url}/Firebird-3.0.7.33374-0.tar.bz2
55 ${_additional_source_url}/zxing-cpp-1.1.1.tar.gz
56 ${_additional_source_url}/skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
57 ${_additional_source_url}/libcmis-0.5.2.tar.xz
58 ${_additional_source_url2}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar # for test suite
59 ${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
60 ${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
61 ${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
64 make-pyuno-work-with-system-wide-module-install.diff
65 mdds-2.0-and-orcus-0.17.diff
66 0001_drop_the_SolarMutex_before_QApplication.patch
67 soffice-template.desktop.in
68 libreoffice-still.sh libreoffice-still.csh)
69 noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
70 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
71 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
72 0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
73 language-subtag-registry-2021-03-05.tar.bz2
74 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
75 d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
76 ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
80 Firebird-3.0.7.33374-0.tar.bz2
81 zxing-cpp-1.1.1.tar.gz
82 skia-m90-45c57e116ee0ce214bdf78405a4762722e4507d9.tar.xz
84 8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar # for test suite
85 odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
86 f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
87 185d60944ea767075d27247c3162b3bc-unowinreg.dll
89 validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
90 sha256sums=('6deaf83a0c2b83c5c8c53c2a9443e2ece51e19469494be2027d4fef3a61bc6a2'
92 'a4d87b16c05e892b741db9683474692c25907f8df162d5c27ba65bdc8fcb6fe2'
94 '2377014eea11b41e998545aae875ee32df097e869ea329f1be07a44c28595d04'
96 '64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1'
97 '1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
98 '75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870'
99 '983941d31ee8d366085cadf28db75eb1f5cb03ba1e5853b98f12f7f51c63b776'
100 'ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a'
101 'd30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370'
102 '1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133'
103 '233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd'
104 '26a03dd60e5ed0979cdaba9cc848242895110ddfdf347d40989ce2f14020f304'
105 '0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4'
106 '940caef1ec7c78e0c34b0f6b94fe42d0f2022915ffc78643d28538a5cfd0f40e'
107 'acb85cedafa10ce106b1823fb236b1b3e5d942a5741e8f8435cc8ccfec0afe76'
108 'e595b3fa2ec320beb0b28f6af56b1141853257c2611686685639cebb3b248c86'
109 'abe0b94d54edb717c58d74263f4ed3d27824d2ce9e9f2ce85a21ab38d993f94d'
110 'd7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2'
111 'f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770'
112 '984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504'
113 'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
114 'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
115 'e61e2a266c7a4374377475254a2f095c1ce2376980b301955a4e5a0d32d3c25b'
116 'caaef7919c6296ab93c7d02607503f91ec965387d038779c0aba9fce78b8e456'
117 'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
118 'fd84c4920b25a6ec4f5f08c852ae10a63a3d19c07d83916964f7fa23597d33dd'
119 '81a8551aaea0ab1750d36fb8bfbd04340a43eaab349a43c1384d21ef6504ab47'
120 'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
121 'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
122 'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
126 cd libreoffice-$_LOver
128 # move external sources into place
129 mkdir "${srcdir}"/ext_sources && pushd "${srcdir}"/ext_sources
130 for source in "${noextract[@]}"; do
131 ln -s "${srcdir}"/$source .
135 # unowinreg.dll must be a file not a symlink or the result will become a broken symlink
136 # /usr/share/libreoffice/sdk/classes/win/unowinreg.dll -> /build/libreoffice/src/185d60944ea767075d27247c3162b3bc-unowinreg.dll
137 rm "${srcdir}"/ext_sources/185d60944ea767075d27247c3162b3bc-unowinreg.dll
138 cp -f "${srcdir}"/185d60944ea767075d27247c3162b3bc-unowinreg.dll "${srcdir}"/ext_sources
140 patch -Np1 -i "${srcdir}"/poppler-22.03.0.patch
141 patch -Np0 -i "${srcdir}"/poppler-22.04.0.patch
143 # fix not upstreamable pyuno paths - FS#54250
144 patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
146 # fix build with current system libixion/liborcus/mdds
147 patch -Np1 -i "${srcdir}"/mdds-2.0-and-orcus-0.17.diff
149 # fix crash on start - FS#73471
150 patch -Np1 -i "${srcdir}"/0001_drop_the_SolarMutex_before_QApplication.patch
152 #use the CFLAGS but remove the LibO overridden ones
155 -O?|-pipe|-Wall|-g|-fexceptions) continue;;
157 ARCH_FLAGS="$ARCH_FLAGS $i"
162 cd libreoffice-$_LOver
164 # strip -s from Makeflags in case you use it to shorten build logs
165 _MAKEFLAGS=${MAKEFLAGS/-s/}
167 # http://site.icu-project.org/download/61#TOC-Migration-Issues
168 CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
170 ./autogen.sh --with-extra-buildid="${pkgver}-${pkgrel}" \
171 --with-vendor="Arch Linux" \
172 --enable-split-app-modules \
173 --with-parallelism=${_MAKEFLAGS/-j/} \
174 --with-external-tar="${srcdir}/ext_sources" \
175 --disable-fetch-external \
176 --enable-release-build \
177 --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc \
178 --libdir=/usr/lib --mandir=/usr/share/man \
189 --enable-introspection \
193 --enable-python=system \
194 --enable-scripting-beanshell \
195 --enable-scripting-javascript \
197 --disable-report-builder \
198 --enable-ext-wiki-publisher \
199 --enable-ext-nlpsolver \
202 --with-system-libcdr \
204 --without-myspell-dicts \
205 --with-system-libvisio \
206 --without-system-libcmis \
207 --with-system-libmspub \
208 --with-system-libexttextcat \
209 --with-system-orcus \
210 --with-system-liblangtag \
211 --with-system-libodfgen \
212 --with-system-libmwaw \
213 --with-system-libetonyek \
214 --with-system-libfreehand \
215 --without-system-firebird \
216 --without-system-zxing \
217 --with-system-libtommath \
218 --with-system-libatomic-ops \
219 --with-system-libebook \
220 --with-system-libabw \
221 --with-system-coinmp \
222 --with-system-dicts \
223 --with-external-dict-dir=/usr/share/hunspell \
224 --with-external-hyph-dir=/usr/share/hyphen \
225 --with-external-thes-dir=/usr/share/mythes \
226 --with-system-beanshell \
227 --with-system-cppunit\
228 --with-system-graphite\
230 --with-system-libnumbertext \
231 --with-system-libwpg \
232 --with-system-libwps \
233 --with-system-redland\
234 --with-system-libzmf \
235 --with-system-gpgmepp \
236 --with-system-libstaroffice \
238 --with-jdk-home="/usr/lib/jvm/default" \
239 --with-ant-home="/usr/share/ant"\
242 --with-system-cairo \
244 --with-system-mythes \
245 --with-system-headers \
246 --without-system-hsqldb \
247 --with-system-clucene \
248 --with-gdrive-client-id=${_google_default_client_id} \
249 --with-gdrive-client-secret=${_google_default_client_secret} \
250 --disable-dependency-tracking
255 mkdir "${srcdir}"/fakeinstall
256 make DESTDIR="${srcdir}"/fakeinstall distro-pack-install
260 # cd "${srcdir}"/build
264 package_libreoffice-still-sdk() {
265 pkgdesc="Software Development Kit for LibreOffice maintenance branch"
266 depends=('libreoffice-still' 'gcc-libs' 'sh' 'make' 'zip' 'gcc' 'java-environment')
267 provides=('libreoffice-sdk')
268 conflicts=('libreoffice-fresh-sdk')
270 for dir in $(grep -h ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
271 install -dm755 "${pkgdir}"/${dir/\%dir/}
274 for file in $(grep -h -v ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
275 dirname=$(dirname $file)
276 [[ -d "${pkgdir}"/$dirname ]] || install -dm755 "${pkgdir}"/$dirname
277 mv "${srcdir}"/fakeinstall/${file} "${pkgdir}"/$file
280 # fix environment path to keep compatibility with other java-environments
281 sed -i -e "s:\/usr\/lib\/jvm\/java-7-openjdk:\$J2SDKDIR:" \
282 "${pkgdir}"/usr/lib/libreoffice/sdk/setsdkenv_unix.sh
285 find "${pkgdir}"/usr/lib/libreoffice/sdk/examples -type f -exec chmod -x {} +
287 # add LibreOfficeKit headers; FS#48066
288 install -dm755 "${pkgdir}"/usr/include/LibreOfficeKit
289 install -v -m644 "${srcdir}"/libreoffice-$_LOver/include/LibreOfficeKit/* "${pkgdir}"/usr/include/LibreOfficeKit
292 package_libreoffice-still() {
293 pkgdesc="LibreOffice maintenance branch"
294 depends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python>=3.7' 'libwpd>=0.9.2' 'libwps'
295 'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl'
296 'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu'
297 'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
298 'libmspub' 'harfbuzz-icu' 'nss' 'clucene' 'hicolor-icon-theme'
299 'desktop-file-utils' 'shared-mime-info' 'libpagemaker'
300 'libxinerama' 'libabw' 'libmwaw' 'libe-book' 'libcups'
301 #'liblangtag' 'libexttextcat' 'libcmis' 'liborcus' # 'libfbclient'
302 'liblangtag' 'libexttextcat' 'liborcus' # 'libfbclient'
303 'libtommath' 'libzmf' 'libatomic_ops' 'xmlsec' 'gpgme' 'libnumbertext'
304 'libfreehand' 'libstaroffice' 'libepubgen' 'libqxp' 'libepoxy' 'box2d'
306 optdepends=('java-runtime: adds java support'
307 'java-environment: required by extension-wiki-publisher and extension-nlpsolver'
308 'pstoedit: translates PostScript and PDF graphics into other vector formats'
309 'libmythes: for use in thesaurus'
310 'beanshell: interactive java -- good for prototyping/macros'
311 'libwpg: library for importing and converting WordPerfect Graphics format'
312 'sane: for scanner access'
313 'unixodbc: adds ODBC database support'
314 'gst-plugins-base-libs: for multimedia content, e.g. in Impress'
315 'libpaper: takes care of papersize'
316 'postgresql-libs: for postgresql-connector'
317 'mariadb-libs: for mysql-connector'
318 'coin-or-mp: required by the Calc solver'
319 'gtk3: for GTK3 integration'
320 'kio: for KF5 KDE desktop integration')
321 backup=(etc/libreoffice/sofficerc
322 etc/libreoffice/bootstraprc
323 etc/libreoffice/psprint.conf
324 etc/profile.d/libreoffice-still.sh
325 etc/profile.d/libreoffice-still.csh)
326 provides=('libreoffice' 'libreoffice-en-US')
327 conflicts=('libreoffice-fresh')
329 mv fakeinstall/* "${pkgdir}"/
331 # put configuration files into place
332 install -dm755 "${pkgdir}"/etc/libreoffice
333 install -m644 "${pkgdir}"/usr/lib/libreoffice/program/{bootstraprc,sofficerc} \
334 "${pkgdir}"/etc/libreoffice/
335 install -m644 "${pkgdir}"/usr/lib/libreoffice/share/psprint/psprint.conf \
336 "${pkgdir}"/etc/libreoffice/
338 # install dummy links to make them found by LibO
339 cd "${pkgdir}"/usr/lib/libreoffice/program/
340 ln -vsf /etc/libreoffice/{bootstraprc,sofficerc} .
341 cd "${pkgdir}"/usr/lib/libreoffice/share/psprint/
342 ln -vsf /etc/libreoffice/psprint.conf .
344 # allow to preset desired VLC
345 install -dm755 "${pkgdir}"/etc/profile.d
346 install -m644 "${srcdir}"/libreoffice-still.{sh,csh} "${pkgdir}"/etc/profile.d/
348 # make pyuno find its modules
349 install -dm755 "${pkgdir}"/usr/lib/python3.10/site-packages
350 ln -svf /usr/lib/libreoffice/program/uno.py \
351 "${pkgdir}"/usr/lib/python3.10/site-packages/uno.py
352 ln -svf /usr/lib/libreoffice/program/unohelper.py \
353 "${pkgdir}"/usr/lib/python3.10/site-packages/unohelper.py
355 # add a symlink required for gnome-documents; FS#51887
356 # https://lists.freedesktop.org/archives/libreoffice/2016-March/073787.html
357 ln -svf /usr/lib/libreoffice/program/liblibreofficekitgtk.so \
358 "${pkgdir}"/usr/lib/liblibreofficekitgtk.so
361 rm -rf "${pkgdir}"/usr/share/libreoffice/sdk
363 # add application descriptions
364 install -dm755 "${pkgdir}"/usr/share/metainfo
365 install -v -m644 "${srcdir}"/libreoffice-$_LOver/sysui/desktop/appstream-appdata/*.xml \
366 "${pkgdir}"/usr/share/metainfo
368 # add kde filemanager templates; FS#61662 - file taken from Debian
369 install -dm755 "${pkgdir}"/usr/share/templates/.source
370 install -v -m644 "${srcdir}"/libreoffice-$_LOver/extras/source/shellnew/soffice.* \
371 "${pkgdir}"/usr/share/templates/.source
373 cat "${srcdir}"/soffice-template.desktop.in \
374 | sed -e "s/@APP@/Writer/" \
375 | sed -e "s/@EXT@/odt/" \
376 | sed -e "s/@TYPE@/text/" \
377 > "${pkgdir}"/usr/share/templates/soffice.odt.desktop
378 cat "${srcdir}"/soffice-template.desktop.in \
379 | sed -e "s/@APP@/Calc/" \
380 | sed -e "s/@EXT@/ods/" \
381 | sed -e "s/@TYPE@/spreadsheet/" \
382 > "${pkgdir}"/usr/share/templates/soffice.ods.desktop
383 cat "${srcdir}"/soffice-template.desktop.in \
384 | sed -e "s/@APP@/Impress/" \
385 | sed -e "s/@EXT@/odp/" \
386 | sed -e "s/@TYPE@/presentation/" \
387 > "${pkgdir}"/usr/share/templates/soffice.odp.desktop
388 cat "${srcdir}"/soffice-template.desktop.in \
389 | sed -e "s/@APP@/Draw/" \
390 | sed -e "s/@EXT@/odg/" \
391 | sed -e "s/@TYPE@/drawing/" \
392 > "${pkgdir}"/usr/share/templates/soffice.odg.desktop
394 # make all i18n lang packages with help section ('1') available to
395 # fix "F1" not opening translated offline help opening in browser
396 # see also /usr/lib/libreoffice/help/en-US/langnames.js
397 echo "var languagesSet = new Set(['en-US','am','ar','ast','bg','bn',\
398 'bn-IN','bo','bs','ca','ca-valencia','cs','da','de','dz','el',\
399 'en-GB','en-ZA','eo','es','et','eu','fi','fr','gl','gu','he',\
400 'hi','hr','hu','id','is','it','ja','ka','km','ko','lo','lt','lv',\
401 'mk','nb','ne','nl','nn','om','pl','pt','pt-BR','ro','ru','si',\
402 'sid','sk','sl','sq','sv','ta','tg','tr','ug','uk','vi','zh-CN','zh-TW'])" \
403 > "${pkgdir}"/usr/lib/libreoffice/help/languages.js