1 # Maintainer: Sébastien Luttringer
7 pkgdesc='Extremely fast compression algorithm'
9 url='http://www.lz4.org/'
12 checkdepends=('diffutils')
14 source=("git+https://github.com/lz4/lz4.git#tag=v$pkgver"
15 'https://github.com/lz4/lz4/commit/8301a21773ef61656225e264f4f06ae14462bca7.patch')
17 'c99da650a79a42db4db23e72146701cce9106383ba45709c5ac89022e36dcfb2')
21 # apply patch from the source array (should be a pacman feature)
23 for src in "${source[@]}"; do
26 [[ $src = *.patch ]] || continue
27 msg2 "Applying patch $src..."
28 patch -Np1 < "../$src"
33 # do not use the main makefile, it calls sub make with -e
34 # exported CLFAGS by makepkg break the version. see FS#50071
36 make -C lib PREFIX=/usr
37 make -C programs PREFIX=/usr lz4 lz4c
42 $pkgname/programs/lz4 /etc/passwd passwd.lz4
43 $pkgname/programs/lz4 -d passwd.lz4 passwd
44 diff -q /etc/passwd passwd
50 make install PREFIX=/usr DESTDIR="$pkgdir"
53 # vim:set ts=2 sw=2 et: