archrelease: copy trunk to testing-x86_64
[arch-packages.git] / ndctl / trunk / PKGBUILD
blob46212dc7b5c2441ae973c80a4661e85245833f15
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=ndctl
4 pkgver=73
5 pkgrel=1
6 pkgdesc='Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel'
7 arch=('x86_64')
8 url="https://github.com/pmem/ndctl"
9 license=('LGPL')
10 depends=('iniparser' 'json-c' 'keyutils' 'kmod' 'systemd-libs' 'util-linux-libs')
11 makedepends=('asciidoctor' 'bash-completion' 'meson' 'systemd' 'xmlto')
12 source=("https://github.com/pmem/ndctl/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
13 sha512sums=('a52a1fb655f044e5cd48b95b3abd89b4f6a991d6439c02e66da6b55947b8a08c279fec873def0b5a18a4e0b670d40e246c333b619fb62f0c6808357d15d847a5')
15 prepare() {
16   # fix location of modprobe.d conf
17   sed -i "s|^modprobedatadir =.*|modprobedatadir = '/usr/lib/modprobe.d/'|" $pkgname-$pkgver/contrib/meson.build
20 build() {
21   arch-meson $pkgname-$pkgver build
22   meson compile -C build
25 check() {
26   meson test -C build --print-errorlogs
29 package() {
30   meson install -C build --destdir "$pkgdir"