archrelease: copy trunk to testing-x86_64
[arch-packages.git] / qt5-charts / trunk / PKGBUILD
blob6cca1a2e53d26a4628b717d728434d28feca8250
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=qt5-charts
5 _basever=5.15.5
6 pkgver=5.15.5+kde+r1
7 pkgrel=1
8 _commit=9a569795f0c3f41ec093e4aa5842a463e2755edb
9 arch=('x86_64')
10 url='https://www.qt.io'
11 license=('GPL3')
12 pkgdesc='Provides a set of easy to use chart components'
13 depends=('qt5-base')
14 makedepends=('qt5-declarative' 'git')
15 optdepends=('qt5-declarative: QML bindings')
16 groups=('qt' 'qt5')
17 _pkgfqn=${pkgname/5-/}
18 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
19 sha256sums=('SKIP')
20 options=(debug)
22 pkgver() {
23   cd $_pkgfqn
24   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
27 prepare() {
28   mkdir -p build
31 build() {
32   cd build
34   qmake ../${_pkgfqn}
35   make
38 package() {
39   cd build
40   make INSTALL_ROOT="$pkgdir" install
42   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
43   find "$pkgdir/usr/lib" -type f -name '*.prl' \
44     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;