archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kexec-tools / trunk / PKGBUILD
blobc6ee34d5d993ac8d09d110ee21150e407eae3fe1
1 # Contributor: Camille Moncelier <pix@devlife.org>, simo <simo@archlinux.org>
2 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
4 pkgname=kexec-tools
5 pkgver=2.0.26
6 pkgrel=1
7 pkgdesc="Load another kernel from the currently executing Linux kernel"
8 arch=('x86_64')
9 url="https://kernel.org/pub/linux/utils/kernel/kexec/"
10 source=("git+https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git#tag=v${pkgver}")
11 makedepends=('git')
12 depends=('zlib' 'xz')
13 license=('GPL2')
15 prepare() {
16   cd $pkgname
17   ./bootstrap
20 build() {
21   cd $pkgname
22   CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
23   ./configure --prefix=/usr --sbindir=/usr/bin --without-lzma
24   make
27 package() {
28   cd $pkgname
29   make DESTDIR="$pkgdir" install
30   install -D -m644 kexec/kexec.8 "$pkgdir"/usr/share/man/man8/kexec.8
33 md5sums=('SKIP')