db-move: moved gnome-terminal from [staging] to [testing] (x86_64)
[arch-packages.git] / gnome-session / trunk / PKGBUILD
blob486eaf5dee03305c052dbd4f346023ab7e48ab60
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-session
4 pkgver=44.0
5 pkgrel=1
6 pkgdesc="The GNOME Session Handler"
7 url="https://gitlab.gnome.org/GNOME/gnome-session"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(
11   dconf
12   gnome-desktop
13   gsettings-desktop-schemas
14   json-glib
15   libgl
16   libsm
17   libxtst
18   systemd
20 makedepends=(
21   docbook-xsl
22   git
23   gtk-doc
24   mesa
25   meson
26   python
27   xmlto
28   xtrans
30 groups=(gnome)
31 _commit=ce29eaa05c68807b9cc5f19f4afb59cc4d806040  # tags/44.0^0
32 source=("git+https://gitlab.gnome.org/GNOME/gnome-session.git#commit=$_commit")
33 b2sums=('SKIP')
35 pkgver() {
36   cd $pkgname
37   git describe --tags | sed 's/\.beta/beta/;s/[^-]*-g/r&/;s/-/+/g'
40 prepare() {
41   cd $pkgname
44 build() {
45   arch-meson $pkgname build
46   meson compile -C build
49 check() {
50   meson test -C build --print-errorlogs
53 package() {
54   meson install -C build --destdir "$pkgdir"
57 # vim:set sw=2 sts=-1 et: